FUNKCE - TYPY

  PDF verze pro tiskCvičení

Line

Základní matematické funkce

SOUČET - SUMA

Funkce SUMA sčítá zadané konstanty nebo obsahy zadaných buněk. Protože tato funkce se používá nejčastěji, má i svou vlastní ikonu v panelu nástrojů STANDARD.

=SUMA(číslo1;číslo2;číslo3; ...... číslo30)
=SUMA(buňka1;buňka2,buňka3; ...... buňka30)
=SUMA(buňka1:buňkaX)
=SUMA(buňka1:buňkaX;číslo1,.....)

Př.: A1=10, A2=20, A3=4, A4=5
=SUMA(10;20;4;5)=39
=SUMA(A1:A4)=39
=SUMA(A1:A3;26)=60 ....

SOUČIN

Funkce SOUČIN násobí zadané konstanty nebo obsahy zadaných buněk.
=SOUČIN(číslo1;číslo2;číslo3; ...... číslo30)
=SOUČIN(buňka1;buňka2,buňka3; ...... buňka30)
=SOUČIN(buňka1:buňkaX)
=SOUČIN(buňka1:buňkaX;číslo1,.....)

Př.: A1=10, A2=20, A3=4, A4=5
=SOUČIN(10;20;4;5)=4000
=SOUČIN(A1:A4)=4000
=SOUČIN(A1:A3;2)=1600

ZAOKROUHLENÍ

Funkce ZAOKROUHLIT zaokrouhluje zadanou konstantu nebo obsah buňky na zadaný počet míst. Pro zaokrouhlování často používáme i ikony pro zmenšení a zvětšení počtu desetinných míst, které najdeme v panelu nástrojů FORMÁT.
=ZAOKROUHLIT(číslo;počet číslic)
=ZAOKROUHLIT(buňka;počet číslic)

„počet číslic“ > 0 : zaokrouhlení na daný počet des. míst
„počet číslic“ = 0 : zaokrouhlení na celé číslo
„počet číslic“ < 0 : zaokrouhlení na daný řád před des. čárkou.

A1=325,478 =ZAOKROUHLIT(A1;2)=325,48
=ZAOKROUHLIT(A1;0)=325
=ZAOKROUHLIT(A1,-2)=300

DRUHÁ ODMOCNINA

Funkce ODMOCNINA vrací druhou odmocninu zadané konstanty nebo obsahu buňky. Argument musí být kladné číslo, druhá odmocnina záporného čísla neexistuje!
=ODMOCNINA(číslo) =ODMOCNINA(buňka)

Př.: A1=25 =ODMOCNINA(25)=5 =ODMOCNINA(A1)=5

LOGARITMY

Funkce LOG vrací hodnotu dekadického logaritmu zadané konstanty nebo obsahu buňky, funkce LN hodnotu přirozeného logaritmu.
=LOG(číslo) =LN(číslo)
=LOG(buňka) =LN(buňka)

Př.: A1=100 =LOG(100)=2 =LOG(A1)=2

GONIOMETRICKÉ FUNKCE

Funkce SIN vrací sinus úhlu zadaného číselnou hodnotou jeho velikosti nebo adresou buňky, ve které se tato hodnota nachází. Funkce COS vrací kosinus a funkce TG tangens. Musíme si však uvědomit, že program EXCEL pracuje s úhly zadanými v radiánech. Napíšeme-li do funkce nebo do tabulky číselnou hodnotu úhlu ve stupních, pro výpočet goniometrických funkcí musíme tuto hodnotu přepočítat na radiány pomocí formule
Ax*PI()/180.

=SIN(číslo) =COS(číslo) =TG(číslo)
=SIN(buňka) =COS(buňka) =TG(buňka)

Př.: A1=45 =SIN(A1)=0,809 číselný údaj je považovaný za 45 rad
=SIN(A1*PI()/180)=0,708 číselný údaj je považovaný za 45°

Line

Základní statistické funkce

ARITMETICKÝ PRŮMĚR

Funkce PRŮMĚR počítá aritmetický průměr zadaných konstant nebo z obsahu zadaných buněk.
=PRŮMĚR(číslo1;číslo2;číslo3; ...... číslo30)
=PRŮMĚR(buňka1;buňka2,buňka3; ...... buňka30)
=PRŮMĚR(buňka1:buňkaX)
=PRŮMĚR)buňka1:buňkaX;číslo1,.....)

Př.: A1=10, A2=20, A3=20, A4=50
=PRŮMĚR(10;20;20;50)=25
=PRŮMĚR(A1:A4)=25

HLEDÁNÍ EXTRÉMNÍCH HODNOT

Funkce MAX vrátí maximální ze zadaných konstant nebo ze zadané skupiny buněk. Funkce MIN vrátí nejmenší hodnotu. Obě funkce pracují úplně stejně.
=MAX(číslo1;číslo2;číslo3; ...... číslo30)
=MAX(buňka1;buňka2,buňka3; ...... buňka30)
=MAX(buňka1:buňkaX)
=MAX(buňka1:buňkaX;číslo1,.....)

Př.: A1=10, A2=20, A3=4, A4=5
=MAX(10;20;4;5)=20
=MAX(A1:A4)=20
=MAX(A1:A3;26)=26 ....

Line

UKÁZKA LOGICKÉ FUNKCE

FUNKCE KDYŽ

Vrací různé hodnoty podle toho, zda je nebo není zadaná logická podmínka splněná. Když má byt výsledkem funkce text, píšeme ho do uvozovek.
=KDYŽ(logický test;hodnota-jestliže ano;hodnota-jestliže ne)

Př. Denní norma je 225 kusů, výkon pana X. zapsaný do buňky C12 je 219 kusů.

=KDYŽ(C12>=225;“norma splněna“;“norma nesplněna“)=norma nesplněna

 

Na obsah

Line

 

Poslední aktualizace: 12.12.2004

webmaster